Browser Support


The following browsers are supported:
  1. Internet Explorer 8+
  2. Mozilla Firefox 7+
  3. Safari 5+
  4. Google Chrome 14+
Older versions of Google Chrome and Mozilla Firefox should also work. We will try to support more browsers in the future. If you find any unusual behaviour, please contact us.